Skip to Content
It is currently November 21st, 2019, 1:44 am

All times are UTC - 6 hours [ DST ]




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: LAME MP3
PostPosted: September 30th, 2013, 3:32 pm 
Offline
New User
New User

Joined: March 5th, 2008, 11:47 am
Posts: 5
Hi..
I was testing SAM cast today and i noticed strange thing with decoded audio using mp3.
First of all i replaced lame_enc.dll (placed at SpacialAudio\SAMCast\plugins) with "other" one. SamCast worked normally. but quality of decoded stream is not same as when i use same lame version to internally decode file or using same dll with "EdCast". Ofcourse, i disabled all processing and DSP etc..
However when i delete lame_enc.dll from dir, encoder does not work. So it seems it uses it properly. But as i said quality is not fully ok.
To be more precize, i am talking about almost invisible differences in audio, but measured it's clearly that it's not same as how that lame version should decode audio!

It is possible that some internal lame settings are not right (?)
This is what i use in Edcast for some important internal lame settings:
LameCBRFlag=1
LameStrictISO=0
LameDisableReservior=0
LameQuality=0
LAMEPreset=12

If it's just that, it might be good to add this options adjustable.

br


Top
 Profile  
Reply with quote  
 Post subject: Re: LAME MP3
PostPosted: September 30th, 2013, 4:56 pm 
Offline
SVS Member
SVS Member

Joined: December 6th, 2004, 9:00 am
Posts: 7882
Location: Aachen (Germany)
As far as I know SAM Cast will not DEcode MP3 or any other audio format at all.
It will only ever ENcode an uncompressed audio stream from a physical or virtual soundcard input.

_________________
Benedikt Bauer - SVS (Spacial Volunteer Support)

We're offering custom PAL / PHP code and general SAM assistance at palscripts.com

My Project:
Send "Now Playing" from SAM to Twitter and/or Facebook | Sourcecode


Top
 Profile  
Reply with quote  
 Post subject: Re: LAME MP3
PostPosted: September 30th, 2013, 5:04 pm 
Offline
New User
New User

Joined: March 5th, 2008, 11:47 am
Posts: 5
Ok my mistake/permutation..
what about my question.. is it possible to call this internal lame settings in samcast?


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group