Skip to Content
It is currently February 26th, 2021, 10:30 pm

All times are UTC - 6 hours [ DST ]




Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: July 14th, 2020, 9:12 pm 
Offline
Senior User
Senior User

Joined: July 23rd, 2007, 2:22 am
Posts: 141
I've just added SSL to my site (listed below), but now using https, but can't get the station to play in the pop-up when you click "Listen".

What exactly am I doing wrong? This is all new to me, but I've been working on SSL certificates for the last couple of days.

Thanks to anyone who can help me.

_________________
Park Magic Radio
http://parkmagicradio.ca


Top
 Profile  
Reply with quote  
PostPosted: July 16th, 2020, 2:34 am 
Offline
SVS Member
SVS Member

Joined: December 6th, 2004, 9:00 am
Posts: 8152
Location: Cologne (Germany)
No, parkmagicradio is not SSL secured. (at least not properly)
If I open https://parkmagicradio.ca, I get a certificate mismatch error, because the cert is only valid for *.dansmith.ca, but not for parkmagicradio.ca.

In firefox I can play the listen link on the HTTP-Site, though. IIRC only Chrome is enforcing the media on HTTPS-only directive at the moment.

_________________
Benedikt Bauer - SVS (Spacial Volunteer Support)

Shop for readymade PAL scripts by countrywesterndj - Or get a custom script made by me (or others)

My Project:
Send "Now Playing" from SAM to Twitter and/or Facebook | Sourcecode


Top
 Profile  
Reply with quote  
PostPosted: July 16th, 2020, 6:34 pm 
Offline
Senior User
Senior User

Joined: July 23rd, 2007, 2:22 am
Posts: 141
Hi Benedikt, would you kindly try it now please? The site is secure, but the pop-up player doesn't work. Rather, it works, but it doesn't play.

_________________
Park Magic Radio
http://parkmagicradio.ca


Top
 Profile  
Reply with quote  
PostPosted: July 17th, 2020, 9:32 am 
Offline
SVS Member
SVS Member

Joined: December 6th, 2004, 9:00 am
Posts: 8152
Location: Cologne (Germany)
Progress: The httpS version is now outright refusing connections instead of showing the wrong certificate. (AKA it's down,broken,offline,choose your word)

_________________
Benedikt Bauer - SVS (Spacial Volunteer Support)

Shop for readymade PAL scripts by countrywesterndj - Or get a custom script made by me (or others)

My Project:
Send "Now Playing" from SAM to Twitter and/or Facebook | Sourcecode


Top
 Profile  
Reply with quote  
PostPosted: July 17th, 2020, 10:10 am 
Offline
Senior User
Senior User

Joined: July 23rd, 2007, 2:22 am
Posts: 141
Try it now.

The overall site is OK if you type in https://www.parkmagicradio.ca, and in Shoutcast DNAS, whenever I try to do a secure play, it shows, "Detected SSL request, checking further", and then does nothing, and when I click the listen link it opens the player but also does nothing. I've added my site key and private key to my shoutcast config file and also added alt port to 443 (which spits out an error).

It's almost like the html5 <audio> code I have needs to be changed somehow to play a secure audio stream, but I'm not sure what that URL is. I have tried various connections, changing the port, adding www in front of the domain name, changing the url to https... nothing seems to work.

_________________
Park Magic Radio
http://parkmagicradio.ca


Top
 Profile  
Reply with quote  
PostPosted: July 18th, 2020, 10:26 am 
Offline
SVS Member
SVS Member

Joined: December 6th, 2004, 9:00 am
Posts: 8152
Location: Cologne (Germany)
Step1: Add https in front of the URL in the Audio Tag
Step2: Fix your SSL certificate for Shoutcast or the reverse proxy you use in front of Shoutcast. The cert is only valid for parkmagicradio.ca and it's subdomains, but not for different ports than the default 443 port. You need to explicitly specify parkmagicradio.ca:8000 as a SAN (alternate name) for Let's Encrypt/Certbot

_________________
Benedikt Bauer - SVS (Spacial Volunteer Support)

Shop for readymade PAL scripts by countrywesterndj - Or get a custom script made by me (or others)

My Project:
Send "Now Playing" from SAM to Twitter and/or Facebook | Sourcecode


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: Bing [Bot] and 65 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group