Skip to Content
It is currently January 28th, 2022, 2:07 am

All times are UTC - 6 hours [ DST ]




Post new topic Reply to topic  [ 12 posts ] 
Author Message
PostPosted: November 7th, 2021, 3:17 pm 
Offline
Senior User
Senior User

Joined: July 23rd, 2007, 2:22 am
Posts: 157
Location: Vancouver, BC, Canada
Hi, I'm a long-time user of SAM Broadcaster and I am a registered and licensed user of SAM Broadcaster Pro, and the latest version that I am able to download without upgrading to a newer license is v2020.5. This suits my needs for what I need it for. I've taken a break from SAM for quite some time, and would like to get back into it again and set my webpage back up. When I run the installer, I get to the MySQL database setup and I enter the credentials, user ID, password and database name, which are all correct, my ports (3306, 1221, 8000-8001) are open. Then after getting to the registration key page, which is correct, I hit "Next", and I get two pop-ups, "Unable to connect to the database. Please make sure the database server is properly installed and running. Also make sure your database login details are correct", and "Failed to create, upgrade or configure database. Please check settings and try again". I have MySQL Community Server 8.0.27.0 installed, my "samdb" database is created, and I can't for the life of me figure out what the problem is. I've never encountered this before, every time I ever tried to install SAMBC, it has worked, up to now. Can anyone help?

Thanks,
Dan


Top
 Profile  
Reply with quote  
PostPosted: November 9th, 2021, 11:48 pm 
Offline
Senior User
Senior User

Joined: July 23rd, 2007, 2:22 am
Posts: 157
Location: Vancouver, BC, Canada
Could anyone help me with this? I even went back to a prior version and am getting the same result.

_________________
Park Magic Radio
http://parkmagicradio.ca


Top
 Profile  
Reply with quote  
PostPosted: November 10th, 2021, 7:48 am 
Offline
SVS Member
SVS Member

Joined: December 6th, 2004, 9:00 am
Posts: 8299
Location: Cologne (Germany)
Can you connect to the database with a DB management tool like MySQL Workbench or HeidiSQL using the credentials you provided to SAM?

_________________
Benedikt Bauer - SVS (Spacial Volunteer Support)

Shop for readymade PAL scripts by countrywesterndj - Or get a custom script made by me (or others)

My Project:
Send "Now Playing" from SAM to Twitter and/or Facebook | Sourcecode


Top
 Profile  
Reply with quote  
PostPosted: November 14th, 2021, 7:28 pm 
Offline
Senior User
Senior User

Joined: July 23rd, 2007, 2:22 am
Posts: 157
Location: Vancouver, BC, Canada
I have MySQL Workbench, and I can't connect to the server with it. It says "Host <host> is not allowed to connect to this MySQL server".

_________________
Park Magic Radio
http://parkmagicradio.ca


Top
 Profile  
Reply with quote  
PostPosted: November 14th, 2021, 7:37 pm 
Offline
SVS Member
SVS Member

Joined: December 6th, 2004, 9:00 am
Posts: 8299
Location: Cologne (Germany)
Are you trying that from remote or from the machine where MySQL runs on?

_________________
Benedikt Bauer - SVS (Spacial Volunteer Support)

Shop for readymade PAL scripts by countrywesterndj - Or get a custom script made by me (or others)

My Project:
Send "Now Playing" from SAM to Twitter and/or Facebook | Sourcecode


Top
 Profile  
Reply with quote  
PostPosted: November 14th, 2021, 8:19 pm 
Offline
Senior User
Senior User

Joined: July 23rd, 2007, 2:22 am
Posts: 157
Location: Vancouver, BC, Canada
I'm trying connect to a remote server that MySQL runs on from my local computer. It has a local IP address. It's almost like it's being blocked by the firewall, but I'm not sure what I should enable. Is it a protocol? Is it something to do with the root password? I know for a fact that the password is correct and all privileges are granted.

_________________
Park Magic Radio
http://parkmagicradio.ca


Top
 Profile  
Reply with quote  
PostPosted: November 15th, 2021, 12:22 am 
Offline
Senior User
Senior User

Joined: July 23rd, 2007, 2:22 am
Posts: 157
Location: Vancouver, BC, Canada
Thanks Mastacheata (and all interested), I'm back up and running! I'm curious about the requests... they work locally - could someone please try a request? I need someone to test it and make sure that requests can be created externally and not just internally. Thanks again.

_________________
Park Magic Radio
http://parkmagicradio.ca


Top
 Profile  
Reply with quote  
PostPosted: November 15th, 2021, 5:50 am 
Offline
SVS Member
SVS Member

Joined: December 6th, 2004, 9:00 am
Posts: 8299
Location: Cologne (Germany)
The requests are sent from either YOUR server or the audiorealm server. Never from the site visitors computer/network.
That means if they work locally and the page is accessible from outside, they should work for everyone else too.

Pro-Tip if you want to try it yourself: Just try sending a request from your phone while Wifi is turned off.

_________________
Benedikt Bauer - SVS (Spacial Volunteer Support)

Shop for readymade PAL scripts by countrywesterndj - Or get a custom script made by me (or others)

My Project:
Send "Now Playing" from SAM to Twitter and/or Facebook | Sourcecode


Top
 Profile  
Reply with quote  
PostPosted: November 15th, 2021, 12:46 pm 
Offline
New User
New User

Joined: May 6th, 2021, 11:31 pm
Posts: 19
Tried visiting your website. Not able to connect. Some kind of server timeout message. I'm using tmobile home internet and they have some strange configuration on the gateway which may be preventing it. IDK.

TMO home internet is not recommended as they do not allow for any configuration of firewall. No port forwarding is possible. Can't use FTP etc.

It may be comparatively inexpensive but - I don't recommend it for use with SAM or any kind of custom config. Just FYI


Top
 Profile  
Reply with quote  
PostPosted: November 17th, 2021, 3:04 am 
Offline
Junior User
Junior User

Joined: January 31st, 2009, 9:43 pm
Posts: 65
Just out of curiosity how did you fix the connection issue? I had to re-install SAM completely fresh as it wont accept any new songs to be added to the category or the database. Tried the solution "extended repair" on HeidiSQL, however nothing was fixed.
I even tried uninstalling the original MariaDB database and replaced it with MySql, however SAM 2021.5 was stubborn to connect to MySQL even though there was a clean uninstallation of SAMBC. Finally I had to revert back to MariaDB and it works fine so far.

Two unknown Issues:
Why it cant connect to MySQL database;
Adding new folder and new songs to the folder.

Mystery for now

_________________
http://www.tamilragam.com


Top
 Profile  
Reply with quote  
PostPosted: December 2nd, 2021, 12:48 am 
Offline
Senior User
Senior User

Joined: July 23rd, 2007, 2:22 am
Posts: 157
Location: Vancouver, BC, Canada
cheekycroak wrote:
Just out of curiosity how did you fix the connection issue? I had to re-install SAM completely fresh as it wont accept any new songs to be added to the category or the database. Tried the solution "extended repair" on HeidiSQL, however nothing was fixed.
I even tried uninstalling the original MariaDB database and replaced it with MySql, however SAM 2021.5 was stubborn to connect to MySQL even though there was a clean uninstallation of SAMBC. Finally I had to revert back to MariaDB and it works fine so far.


Hi there, I ended up installing VMWare Workstation and creating a Windows 2019 Server VM and installing SAM there from scratch, same as you did - it went without a hitch. I just won't be installing SAM on Windows 10 going forward, I've just had way too many problems trying to install lit on Windows 10. Then I created a 2019 VM for my MySQL server, and another 2019 VM for my web server. I love this configuration, my sites are lightning fast, easy to care for, and VMWare runs unobtrusively in the background on top of Windows 10.

_________________
Park Magic Radio
http://parkmagicradio.ca


Last edited by dan40 on December 2nd, 2021, 1:28 am, edited 1 time in total.

Top
 Profile  
Reply with quote  
PostPosted: December 2nd, 2021, 1:26 am 
Offline
Senior User
Senior User

Joined: July 23rd, 2007, 2:22 am
Posts: 157
Location: Vancouver, BC, Canada
7276922181 wrote:
Tried visiting your website. Not able to connect. Some kind of server timeout message. I'm using tmobile home internet and they have some strange configuration on the gateway which may be preventing it. IDK.


Try again, it should be OK now, it's been up for almost a week full time with no issues. If you still can't get to it, I'd blame T-Mobile. :)

_________________
Park Magic Radio
http://parkmagicradio.ca


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 12 posts ] 

All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: Bing [Bot] and 24 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group