Skip to Content
It is currently September 28th, 2022, 4:14 am

All times are UTC - 6 hours [ DST ]




Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: February 4th, 2022, 6:19 am 
Offline
cat's pajamas

Joined: January 18th, 2005, 7:03 pm
Posts: 285
Location: UK.
After some problems with the install, I now can't run the backup option. I get this error message.

Code:
Backup Failed! Can't create/write to file
'C:\Users\shang\AppData\Local\SpacialAudio\SAMBC\Backup\Backup_2022-02-04.111432\adz.csv"
(OS errno 13 - Permission denied)


If anyone knows how to fix this, thanks.

Robert

_________________
Robert Chalmers
Radio Daze
YouTube Creator.
Streaming with SAM since 1986
@ra.chalmers


Top
 Profile  
Reply with quote  
PostPosted: February 4th, 2022, 7:06 am 
Offline
cat's pajamas

Joined: January 18th, 2005, 7:03 pm
Posts: 285
Location: UK.
Found it in another post. No big secret as it turns out...
The simplest option seems to be to simply change the user that the MySQL service is running as, to now run using the Local System account, which will have the necessary access to the SAM backup folder.

In order to do this, we want to access the Services window. This can be done by clicking the Start button, and typing in services, and then clicking the Services icon that should show up at the top, with the gears icon:

Image

You can also use the Windows key + R to open the Run window, and type in services.msc, or open Task Manager, click on the Serivces tab, and click on the Services... button in the bottom right corner.

Once that Services window is open, you want to locate the MySQL service in that list of services, which should be named MySQL by default.
Once you find that service, double click on it to open the service properties window.
Once it's open, click on the Log On tab on the top, and it should look like this:

Image

As you should be able to see, the service is set to run using the Network Service account by default.

To switch it to use the Local System account, simply click on the "radio button" next to the Local System account option on the top, so that it now looks like this:

Image

Once you do that, click on the Apply button on the bottom of that window, which should show you this message window:

Image

This means that we will have to restart the MySQL service in order for it to start running using the newly selected Local System account user.

Click on the OK button on the message window, and and then on the OK button on the MySQL service properties window.

In order to restart the service, right click on the MySQL service in the Service window, and click on the Restart option.
A Service Control window should pop up, showing you while Windows stops and then starts the service.

Once that's finished, you should now be able to use the SAM backup and restore options without any issue:

_________________
Robert Chalmers
Radio Daze
YouTube Creator.
Streaming with SAM since 1986
@ra.chalmers


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group