Skip to Content
It is currently February 25th, 2021, 10:49 am

All times are UTC - 6 hours [ DST ]




Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: June 22nd, 2018, 2:47 pm 
Offline
Super User
Super User

Joined: November 1st, 2005, 8:09 am
Posts: 569
Location: NJ NYC
Im not sure why this is happening.
I just reinstalled SAM after reinstalling windows.

I just can not get this connected for some reason.
The latest error is

Quote:
Parse error: Invalid numeric literal in /homepages/38/d692002752/htdocs/antifmradio.com/SAM4/library/Common/form.php on line 51


Really?
All i am editing is the CONFIG files
Config.php
dbconfig.xml.php

Im pretty sure i have the correct information in both files. I have read them line by line.

djconfig.xml has the following:

Quote:
<Database>
<Driver>MYSQL</Driver>
<Host>Outside IP Address of Machine where SAM is running</Host>
<Port>3306</Port>
<Database>SAMDB</Database>
<Username>User i created which is NOT ROOT</Username>
<Password>Password for user who is NOT ROOT</Password>
</Database>
</CONFIG>


I checked CANYOUSEEME for ports to be open and port forwarding was done correctly.

So whats up with the error at "/Common/form.php" ?

Im using NEW files. and yes i am still using SAM Pro 4.9.8
I had no need to upgrade it.


Top
 Profile  
Reply with quote  
PostPosted: June 23rd, 2018, 9:02 am 
Offline
SVS Member
SVS Member

Joined: December 6th, 2004, 9:00 am
Posts: 8152
Location: Cologne (Germany)
You must've updated your webserver/PHP as well, right?

That is the typical problem for running the "middle-aged" templates that came with 4.7.4-2018.2 on a PHP7 interpreter.
I only noticed these problems myself by the end of march and submitted my bugfixes to Spacial who then included a fixed version of samPHPweb with 2018.3.

You can either get the official fix from Spacial by upgrading to 2018.3/2018.4 or you trust me and take the instructions and files that were the basis for the 2018.3 update from over here:
viewtopic.php?f=22&t=53771

_________________
Benedikt Bauer - SVS (Spacial Volunteer Support)

Shop for readymade PAL scripts by countrywesterndj - Or get a custom script made by me (or others)

My Project:
Send "Now Playing" from SAM to Twitter and/or Facebook | Sourcecode


Top
 Profile  
Reply with quote  
PostPosted: June 23rd, 2018, 7:43 pm 
Offline
Super User
Super User

Joined: November 1st, 2005, 8:09 am
Posts: 569
Location: NJ NYC
Mastacheata wrote:
You must've updated your webserver/PHP as well, right?

That is the typical problem for running the "middle-aged" templates that came with 4.7.4-2018.2 on a PHP7 interpreter.
I only noticed these problems myself by the end of march and submitted my bugfixes to Spacial who then included a fixed version of samPHPweb with 2018.3.

You can either get the official fix from Spacial by upgrading to 2018.3/2018.4 or you trust me and take the instructions and files that were the basis for the 2018.3 update from over here:
viewtopic.php?f=22&t=53771



thanks very much Cheata. Tomorrow ill get to work on editing my files (Copies of my files actually lol) so i dont lose my originals.


Top
 Profile  
Reply with quote  
PostPosted: June 28th, 2018, 8:46 pm 
Offline
Super User
Super User

Joined: November 1st, 2005, 8:09 am
Posts: 569
Location: NJ NYC
well here i am with the changes in place. ( did not do the OPTIONAL changes)
I did do the MUST HAVE changes.

It must be working because now i can get the Playing.php page to load but im still getting a permissions error.
For example.

http://www.antifmradio.com/SAM4

Youll notice the NOT ALLOWED culprit is " infong-us11.lxa.perfora.net "
This is the address of a 1and1 hosting server.
With that info i ended up making sure to add
infong-us11.lxa.perfora.net
and
the IP address of that host server to the ALLOWED list in (SAM Allowed Request Window)
But i still get the error.

Is this an issue with the Hosting company at this point?

---------------EDITED-----------
Also keep in mind i am using CLOUDFLARE to manage the site loading so with CloudFlare
the website IP has been taken into consideration and i added that in as well. I used the information from the domains DNS settings.


Top
 Profile  
Reply with quote  
PostPosted: June 29th, 2018, 6:22 am 
Offline
SVS Member
SVS Member

Joined: September 11th, 2004, 1:51 pm
Posts: 670
Location: PA
Quote:
Oops! Something went wrong...
Host 'infong-us11.lxa.perfora.net' is not allowed to connect to this MySQL server


You need to allow infong-us11.lxa.perfora.net through MySQL. If you haven't already and if you are using "Workbench".
"I Found" the easiest way is to do the following:


Load up workbench
Select "Users and Privileges"
Add Account

Login name: MySQL username
Auth type: Standard
Limit to hosts matching: % <--- Yes, a percent symbol
Password: MySQL password
Confirm Password: (Same as above)

Click Apply

On your SAM config file, be sure the MySQL username and password match that of your SAMDB info.

That should get you passed the Host not allowed error.

_________________
Mark L. - SVS (Spacial Volunteer Support)
-------------------------------------------------
DJ Fire - CEO
http://www.crossfire-radio.com


Top
 Profile  
Reply with quote  
PostPosted: June 29th, 2018, 1:01 pm 
Offline
Super User
Super User

Joined: November 1st, 2005, 8:09 am
Posts: 569
Location: NJ NYC
Thanks Trex. I already had the additional user allowcated in Workbench. I simply had to change the "Limit to hosts matching" from local to %

Saved. Refreshed. All clear.

Thanks again


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 17 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group