Skip to Content
It is currently March 3rd, 2021, 4:12 pm

All times are UTC - 6 hours [ DST ]




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Unicode (UTF-8) Support
PostPosted: January 16th, 2020, 12:58 am 
Offline
Junior User
Junior User

Joined: June 19th, 2004, 8:20 am
Posts: 66
Location: Vatican City
Hi Guys, I've stuck with you since SAM v2... it's been a while. And ever since the beginning I've been requesting Unicode support (both for tags and filenames). It's 2020... and you've have been doing this a long time. Don't you think it's time? I mean, I just updated to 2020.1... and you know what was the "amazing new feature" added?

Quote:
-v2020.1 (13 January 2020)
* Notes window for quick notes or static information area.


Really guys? That's the best the talents at Spacial Audio has to offer? Aside from the fact that we've been going for a few years now with absolutely NO major improvements, it would be at least satisfying to be able to add music that cannot be addressed with western alphabets.

Please, just do it once and for all. We are all waiting.

Thanks in advance.

_________________

Image

Festerology: A Religion... not a cult! • Festerologist: He who worships the great FesterHead! • Festerism: Festerological Fanatism!!!



Top
 Profile  
Reply with quote  
PostPosted: April 21st, 2020, 6:10 am 
Offline
New User
New User

Joined: April 20th, 2020, 11:10 pm
Posts: 8
Motion seconded by this here Frenchie!!!!


Top
 Profile  
Reply with quote  
PostPosted: April 21st, 2020, 11:49 am 
Offline
SVS Member
SVS Member

Joined: December 6th, 2004, 9:00 am
Posts: 8156
Location: Cologne (Germany)
SpeedyCharly wrote:
Motion seconded by this here Frenchie!!!!

That's strange. German here and I don't have any problems with accented characters like those used in the french language.
In fact everything that can be displayed as either accented or with diactrics works just fine

It's only when using completely different lettering systems that SAM goes down.
The stranges thing, though: The editor and the listview behave completely different.
While it's no problem to enter cyrillic or greek letters in the Song Editor, as soon as you save they're mostly gone and replaced by ?.
The editor however has problems with arabic letters for some reason you can't even enter those letters. They're also replaced by ? in the input field already.


Attachments:
Anmerkung 2020-04-21 182621.png
Anmerkung 2020-04-21 182621.png [ 1.59 KiB | Viewed 1711 times ]

_________________
Benedikt Bauer - SVS (Spacial Volunteer Support)

Shop for readymade PAL scripts by countrywesterndj - Or get a custom script made by me (or others)

My Project:
Send "Now Playing" from SAM to Twitter and/or Facebook | Sourcecode
Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 19 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group