Skip to Content
It is currently December 4th, 2022, 8:00 pm

All times are UTC - 6 hours [ DST ]




 [ 6 posts ] 
Author Message
PostPosted: August 27th, 2022, 2:37 am 
Offline
Senior User
Senior User

Joined: July 23rd, 2007, 2:22 am
Posts: 176
Location: Vancouver, BC, Canada
Hey all, I just got some good connections going tonight and noticed this: if I have say, 30 listeners, every half hour or so on the 00 and 30 intervals, about 20 of those connections will drop out, and slowly over the next several minutes, it will build up to what it was, and then do the same thing over again. Is there something in my sc_serv config file I should be setting to prevent this from happening? I have a feeling some listeners are getting tired of being disconnected and I don't know how to fix it. Any ideas? Thanks!

Dan

_________________
Park Magic Radio
http://parkmagicradio.ca


Top
 Profile  
 
PostPosted: August 27th, 2022, 11:33 am 
Offline
Senior User
Senior User

Joined: July 23rd, 2007, 2:22 am
Posts: 176
Location: Vancouver, BC, Canada
Here's an example. How do I fix this?


Attachments:
Screenshot 2022-08-27 093227.png
Screenshot 2022-08-27 093227.png [ 7.86 KiB | Viewed 582 times ]

_________________
Park Magic Radio
http://parkmagicradio.ca
Top
 Profile  
 
PostPosted: August 30th, 2022, 5:30 am 
Offline
Senior User
Senior User

Joined: September 24th, 2007, 2:01 pm
Posts: 198
Im not an expert, but I would check your server settings. There is usually an option to drop inactive connections after a period of time, which is intended to protect your bandwidth usage from robots. You may need to remove that restriction if it is applied.


Top
 Profile  
 
PostPosted: August 30th, 2022, 11:54 pm 
Offline
Senior User
Senior User

Joined: July 23rd, 2007, 2:22 am
Posts: 176
Location: Vancouver, BC, Canada
Assuming this is the shoutcast "autodumpsourcetime", I already have it set to 30 minutes. I wonder if this is where it's coming from. Should I even be using that setting, or maybe setting it to "0" to turn it off?

_________________
Park Magic Radio
http://parkmagicradio.ca


Top
 Profile  
 
PostPosted: August 31st, 2022, 1:45 pm 
Offline
Junior User
Junior User

Joined: February 22nd, 2019, 1:20 pm
Posts: 27
If you are using Shoutcast V1: It's not "autodumpsourcetime". => AutoDumpSourceTime specifies how long, in seconds, the source stream is allowed to be idle before the server disconnects it. 0 will let the source stream idle indefinately before disconnecting. The default is 30.
AutoDumpSourceTime=30

Mine is set to 30 seconds (Default value)

Check for: "ListenerTimer" about the value set - if you are using Shoutcast V1: =>... ListenerTimer is a value in minutes of maximum permitted time for a connected listener. If someone is connected for longer than this amount of time, in minutes, they are disconnected. When undefined, there is no limit defined. Default is undefined. ; ListenerTimer=??? (Check it out).

Mine is set to 600 minutes.


Top
 Profile  
 
PostPosted: August 31st, 2022, 10:19 pm 
Offline
Senior User
Senior User

Joined: July 23rd, 2007, 2:22 am
Posts: 176
Location: Vancouver, BC, Canada
I use Shoutcast V2. "Listener Timer" you describe in v1, in v2 is "streamlistenertime_1=180". This is my setting (180 minutes = 3 hours). I've had this setting for quite some time. When the user reaches 3 hours, he'll have to reconnect to keep listening.

I've changed my autodumpsourcetime to 30. It was 0. Lesson learned. Thanks for that.

_________________
Park Magic Radio
http://parkmagicradio.ca


Top
 Profile  
 
Display posts from previous:  Sort by  
 [ 6 posts ] 

All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: Google [Bot] and 14 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group